Can't connect to ecu, loss of engine power

#1 by Phil ( Guest ) , Sat Apr 13, 2019 12:58 pm

OK, 2003 l200 4work. A bit of a knacker...
About a year ago, my big end decided to get up and f*** off. I left her out the back for a while and only just got round to sorting it out. Rebuilt the block, the head and turbo were only a year old so didn't worry about them. After the rebuild it fired up with no issues except the eml light, I found the Vgt solinoid was not working, but when fed power straight from the battery, the actuator arm moved nicely to the top adjuster screw. I had to start using it to get to my new job and was happy enough to plod around with no boost. I had tried to connect my torque pro app to it but said it couldn't talk to the ecu. A couple of nights ago driving home and all my power just went, engine running, no smoke, no missing, would rev but only to 2.5k and while driving about 1.5k on the flat. The AA bloke had no idea and went for his laptop and also couldn't connect...
I have checked the timing, air, compression, fuel lines and filter, vacuum hoses, and am at a loss, oh and yes it's got plenty of diesel.
Can someone please help, I'm loosing my mind!!!


Phil

RE: Can't connect to ecu, loss of engine power

#2 by Guest , Sun Apr 14, 2019 1:37 pm

The Classic L200 isn't OBD so most code readers will not connect to it.
It uses a protocol called MUT3.
Snap on & Delphi will read them,

Nick
(Sorry wasn't logged in when I posted Doh!)


Last edited Sun Apr 14, 2019 1:39 pm | Top

RE: Can't connect to ecu, loss of engine power

#3 by ronniecabers , Sun Apr 14, 2019 4:43 pm

Have you checked the vacuum with a guage? You say you've checked the pipes , but was that for leaks or just that they are in the right place? Sounds to me like , after the rebuild you may have some pipes in thwe wrong place ...possibly


Thread locking available here...no fee!

Moderator


 
ronniecabers
Forum Legend
Posts: 10.465
Date registered 11.09.2012


RE: Can't connect to ecu, loss of engine power

#4 by krutly , Sun Apr 14, 2019 5:39 pm

get yourself signed up to the forum bud as there are some pictures on here somewhere of the vac pipe layouts


SOUTHWEST ENGLAND - AREA REP
2003 4life now sold
2011 walkinshaw , lego mechanic


 
krutly
Forum Legend
Posts: 16.749
Date registered 10.21.2011


   

Series 5 Barbaian
Clutch resavoir

Xobor Create your own Forum with Xobor