New turbo, now kangaroo juddering

#1 by jamesd , Wed May 01, 2019 7:46 am

Hi all

had the overboost issue so swopped solenoids and eventually the turbo on my K74
Turbo went in yesterday but since then i get a massive juddering on partial throttle, if i floor it i get a bit of a hold back and then it accelerates away hard.
The juddering comes in at any rev or gear if i only use partial throttle or hold a speed on partial throttle.
The actuator settings look a bit strange on the new compared to the old but i didnt think that would effect it on partial as in the min screw does not touch the actuator arm at all.
Anyone any ideas? Doing my head in now
Thanks as always


jamesd  
jamesd
Posts: 153
Date registered 10.22.2017


RE: New turbo, now kangaroo juddering

#2 by jamesd , Wed May 01, 2019 7:48 am

also no eml coming on when it happens


jamesd  
jamesd
Posts: 153
Date registered 10.22.2017


RE: New turbo, now kangaroo juddering

#3 by jamesd , Wed May 01, 2019 8:02 am

Any chance its the fact the min boost screw is no where near the actuator arm?


jamesd  
jamesd
Posts: 153
Date registered 10.22.2017


RE: New turbo, now kangaroo juddering

#4 by ronniecabers , Wed May 01, 2019 8:31 am

Have you checked down in the tech section for Classics for the How to's,? There is one for VGT turbo setup, also there is one for overboost too. I would link but I'm on my phone lol


Thread locking available here...no fee!

Moderator


 
ronniecabers
Forum Legend
Posts: 10.501
Date registered 11.09.2012


RE: New turbo, now kangaroo juddering

#5 by jamesd , Wed May 01, 2019 8:34 am

i had a look at a standard set up and mine seems way off. arm itself is parallell to the ends of the screws, both screws seem set at the same level of thread in. probably the min boost needs adjusting?? might explain the kangaroo on low load and pulls like a train on full throttle


jamesd  
jamesd
Posts: 153
Date registered 10.22.2017


RE: New turbo, now kangaroo juddering

#6 by jamesd , Wed May 01, 2019 8:40 am


jamesd  
jamesd
Posts: 153
Date registered 10.22.2017


RE: New turbo, now kangaroo juddering

#7 by jamesd , Wed May 01, 2019 8:40 am

Bad pic but will get a better one later


jamesd  
jamesd
Posts: 153
Date registered 10.22.2017


RE: New turbo, now kangaroo juddering

#8 by ronniecabers , Wed May 01, 2019 8:42 am

Find another member locally , and adjust yours to their setup....gotta be worth a try!


Thread locking available here...no fee!

Moderator


 
ronniecabers
Forum Legend
Posts: 10.501
Date registered 11.09.2012


RE: New turbo, now kangaroo juddering

#9 by jamesd , Wed May 01, 2019 9:49 am

Im in ireland 😭😭😭 ill look at the one i took off and try and match it up. Makes sense its this though is it?


jamesd  
jamesd
Posts: 153
Date registered 10.22.2017


RE: New turbo, now kangaroo juddering

#10 by jamesd , Wed May 01, 2019 5:29 pm

Ok checked properly now amd the actuator is set properly.would a plumbin issue be it or egr?


jamesd  
jamesd
Posts: 153
Date registered 10.22.2017


RE: New turbo, now kangaroo juddering

#11 by Heathen , Wed May 01, 2019 6:54 pm

Is the actuator arm doing what it's supposed to during idle and when you rev it?


'02 K74 single cab.


 
Heathen
Posts: 886
Date registered 05.20.2016


RE: New turbo, now kangaroo juddering

#12 by jamesd , Thu May 02, 2019 8:14 am

Ya its moving freely. found the issue anyway i think ..... the pipe from the actuator to the boost sensor had a small crack just above the actuator nipple. seems ok now


jamesd  
jamesd
Posts: 153
Date registered 10.22.2017


RE: New turbo, now kangaroo juddering

#13 by jamesd , Fri May 10, 2019 4:19 pm

Right that wasnt the issue.feels like a fuel cut.revs drop 3-400rpm and bounce up again.nothin noticed om acceleration.only deceleration or holding partial throttle.the turbo would hardly cause that wiuld it?


jamesd  
jamesd
Posts: 153
Date registered 10.22.2017


RE: New turbo, now kangaroo juddering

#14 by Heathen , Fri May 10, 2019 4:34 pm

If you unplug the brown solenoid, the turbo will not provide any boost, you'll be a bit sluggish, but might help to rule that out as the problem. You need to have a look at the actuator arm when idling and when revving - make sure it's working as it should.


'02 K74 single cab.


 
Heathen
Posts: 886
Date registered 05.20.2016


RE: New turbo, now kangaroo juddering

#15 by jamesd , Fri May 10, 2019 5:52 pm

Thanks for that.ill give it a go.arm works away fine.freely moving.spools fine too.its weird.if it was on full throttle id say somethin hut a cut on light partisl throttle is a pain.


jamesd  
jamesd
Posts: 153
Date registered 10.22.2017


   

Auto box sticking
k74 wing mirrors

Xobor Create your own Forum with Xobor