Surging

#1 by Foxer , Tue Feb 12, 2019 12:33 am

When I'm driving, the truck starts surging at 2000rpm in every gear. It drives fine above and below 2k... In neutral no surging at any revs. Revs drop as normal when changing gear so hopefully not the SCV?

I've changed the fuel filter since it started but it seems no better. A friend recommended cleaning out the EGR but I'm thinking a trip to the dealers (god forbid) may be in order.

Have been thinking it might be worth checking transmission fluid? But I'm really not sure.

2010 L200, approx 90000 miles

Any suggestions?

Thanks

Steve


L200 Barbarian


Foxer  
Foxer
Posts: 16
Date registered 05.28.2016


RE: Surging

#2 by paulw , Tue Feb 12, 2019 11:34 am

I had similar on my D2 , changed all the sensors, Then somebody suggested cleaning the maf sensor with Proper maf cleaner.Don't use contact cleaner. It worked. Think it is about a tenner a can, spray it on the sensor and all through the holder, let it evaporate and away you go!I left mine overnight to make sure. Might work, but for a tenner it could save a hefty bill?


did have warrior, but crossed over to disco 2.
Thought I could see light at the end of the tunnel, but it was somebody with a torch bringing more work!
Landies don't leak oil, they just sweat


 
paulw
Posts: 5.471
Date registered 10.06.2011


RE: Surging

#3 by paulw , Tue Feb 12, 2019 11:37 am


did have warrior, but crossed over to disco 2.
Thought I could see light at the end of the tunnel, but it was somebody with a torch bringing more work!
Landies don't leak oil, they just sweat


 
paulw
Posts: 5.471
Date registered 10.06.2011


RE: Surging

#4 by Foxer , Tue Feb 12, 2019 3:19 pm

Thanks Paul I'll give that a go


L200 Barbarian


Foxer  
Foxer
Posts: 16
Date registered 05.28.2016


RE: Surging

#5 by Dan83590 , Yesterday 11:04 pm

Any good, did it work?



Dan83590  
Dan83590
Posts: 14
Date registered 01.29.2019


   

ABS and Traction Control lights illuminated

Xobor Create your own Forum with Xobor